Recover a non working "bricked" Linkstation

From NAS-Central Buffalo - The Linkstation Wiki
Revision as of 18:46, 1 October 2006 by 67.161.202.190 (Talk)

Jump to: navigation, search

Any information how to recover a non working, bricked Linkstation should get here.


Firmware Reinstallation

The following steps can be used to "reanimate" a Linkstation:

  • disconnect disk from internal mainboard and power.
  • connect disk to a PC with knoppix via a USB-IDE adapter or directly to the IDE controller. If you change the IDE setting on your hard drive to match it to a "Slave" setting, remember to put the jumper back to "Master" before connecting back the hard drive to the Linkstation
  • start knoppix in terminal mode "knoppix 2"
  • remove all partitions:

For a USB-IDE connection:

parted /dev/sda

For IDE direct connection:
hda = Primary Master hdb = Primary Slave hdc = Secondary Master hdd = Secondary Slave

So if you used Primary Master you would type:

parted /dev/hda

After this, the commands are the same for USB & IDE direct:

rm 1
rm 2
rm 3
rm 4
quit
  • (optional) For Windows users who do not wish to become familiar with Knoppix, Google and get "Explore2fs". When the LS drive is connected to the IDE controller on your pc, this application may allow you to retrieve data from the LS disk and copy (export) it to your Windows drive. You can then use Windows Computer Management --> Disk Management to delete the partitions on the LS drive and continue with the directions as posted here.
  • reconnect disk to LS
  • power on LS (Reset button not pressed)
  • disable Windows Firewall & set your PC's IP Address to 192.168.11.11
  • Get the proper Firmware at: http://downloads.linkstationwiki.net/
  • unpack HD-H*.zip (use the proper firmware for your LS)
  • start HD-H*FWUpdate.exe (use the proper updater for your LS)
  • start update, following messages appear:
Settings are being saved
Firmware is being transmitted
LinkStation Firmware has been renewed
Settings are being restored
  • if You get the following message You are done.
The firmware has been renewed
  • But because the reformatting (?)and partitioning takes too long,

the diskfill LED may blink and you may get:

Attempt to renew firmware has failed
  • if so, wait until Diskfull LED goes off after some minutes.
  • press "search" again.
  • start update again.
  • after all the other messages You should get this time:
The firmware has been renewed
  • the LS is now reachable via telnet and the "old" IP.

so switch back IP settings and reenable the windows firewall.

  • use telnet to get a prompt:
telnet linkstation
  • set root password:
passwd
  • change bash to login:
vi /etc/init.d/telnet
  • add a new guest user
useradd -m -d /home/guest guest
  • and ...
reboot
Link.png This article is currently a stub. You can help this Wiki by expanding it

. This template will categorize articles that include it into Category:Stubs.