Difference between revisions of "Talk:Linux NTFS support"

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
(I need a Howto to compile kernel and Fuse for LS-XHL = LS-CHL(V2).)
 
Line 2: Line 2:
 
You need to compile the fuse support in your kernel and to compile Fuse and NTFS-3G."
 
You need to compile the fuse support in your kernel and to compile Fuse and NTFS-3G."
  
Im interested in Fuse and NTFS-3G on LS-XHL (Kirkwood).
+
Im interrested in Fuse and NTFS-3G on LS-XHL (Kirkwood).
  
 
I am using http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ls-mvkw-bootstrap_1.2-7_arm.xsh.
 
I am using http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ls-mvkw-bootstrap_1.2-7_arm.xsh.
  
I have installe http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ntfs-3g_2009.4.4-1_arm.ipk with Errors. Fuse is needet.
+
I have installed http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ntfs-3g_2009.4.4-1_arm.ipk with Errors. Fuse is needed.
  
 
I need a Howto to compile kernel and Fuse for LS-XHL = LS-CHL(V2).
 
I need a Howto to compile kernel and Fuse for LS-XHL = LS-CHL(V2).
 +
 +
I am not using Debian, only ipkg. I hope, it is possible to make fuse.ko und insmod it with Shonks 1.31 Firmware.
 +
 +
'''My experiment:'''
 +
 +
With reference to:
 +
[http://forum.qnap.com/viewtopic.php?p=126475&sid=7146b3b737486c0f068e9498b92cd6f5]
 +
 +
Telnet Login on LS-XHL as root
 +
 +
ipkg install gcc
 +
ipkg install make
 +
ipkg install coreutils
 +
ipkg install gawk
 +
ipkg install sed
 +
ipkg install diffutils
 +
ipkg install pkgconfig
 +
export CC=/opt/bin/gcc
 +
export PATH=/opt/bin:/opt/sbin:/usr/local/bin:/usr/ucb:/bin:/usr/bin
 +
 +
 +
File download and copy to share:
 +
http://downloads.sourceforge.net/projec ... 8.4.tar.gz
 +
 +
Telnet
 +
 +
cd /mnt/disk1/share
 +
tar xvzf fuse-2.8.4.tar.gz
 +
cd fuse-2.8.4
 +
./configure --prefix=/opt
 +
make; make install
 +
 +
 +
Unfortunately, I get an error message instead of a fuse.ko - file.
 +
 +
Code:
 +
/opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_sa_restorer_v2@GLIBC_PRIVATE'
 +
/opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_rt_sa_restorer_v2@GLIBC_PRIVATE'
 +
/opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_rt_sa_restorer_v1@GLIBC_PRIVATE'
 +
/opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_sa_restorer_v1@GLIBC_PRIVATE'
 +
collect2: ld returned 1 exit status
 +
make[1]: *** [ulockmgr_server] Error 1
 +
make[1]: Leaving directory `/mnt/disk1/share/fuse-2.8.4/util'
 +
make: *** [install-recursive] Error 1
 +
 +
My kernel do not support Fuse.
 +
 +
Is this my Problem?

Revision as of 14:22, 17 July 2010

"This solution is the easiest to install, and is available for MIPS, PPC & ARM devices ! You need to compile the fuse support in your kernel and to compile Fuse and NTFS-3G."

Im interrested in Fuse and NTFS-3G on LS-XHL (Kirkwood).

I am using http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ls-mvkw-bootstrap_1.2-7_arm.xsh.

I have installed http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/ntfs-3g_2009.4.4-1_arm.ipk with Errors. Fuse is needed.

I need a Howto to compile kernel and Fuse for LS-XHL = LS-CHL(V2).

I am not using Debian, only ipkg. I hope, it is possible to make fuse.ko und insmod it with Shonks 1.31 Firmware.

My experiment:

With reference to: [1]

Telnet Login on LS-XHL as root

ipkg install gcc ipkg install make ipkg install coreutils ipkg install gawk ipkg install sed ipkg install diffutils ipkg install pkgconfig export CC=/opt/bin/gcc export PATH=/opt/bin:/opt/sbin:/usr/local/bin:/usr/ucb:/bin:/usr/bin


File download and copy to share: http://downloads.sourceforge.net/projec ... 8.4.tar.gz

Telnet

cd /mnt/disk1/share tar xvzf fuse-2.8.4.tar.gz cd fuse-2.8.4 ./configure --prefix=/opt make; make install


Unfortunately, I get an error message instead of a fuse.ko - file.

Code: /opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_sa_restorer_v2@GLIBC_PRIVATE' /opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_rt_sa_restorer_v2@GLIBC_PRIVATE' /opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_rt_sa_restorer_v1@GLIBC_PRIVATE' /opt/lib/gcc/arm-none-linux-gnueabi/4.2.3/../../../../arm-none-linux-gnueabi/lib/libpthread.so: undefined reference to `__default_sa_restorer_v1@GLIBC_PRIVATE' collect2: ld returned 1 exit status make[1]: *** [ulockmgr_server] Error 1 make[1]: Leaving directory `/mnt/disk1/share/fuse-2.8.4/util' make: *** [install-recursive] Error 1

My kernel do not support Fuse.

Is this my Problem?