Difference between revisions of "Talk:Mldonkey - multi-network file-sharing client"

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
Line 25: Line 25:
  
 
so first i have to upgrade the libs - right?
 
so first i have to upgrade the libs - right?
 +
 +
----
 +
tried to compile it instaed of digging into dependencies:
 +
but after ./configure --enable-batch --disable-gui i got in the end:
 +
 +
-----------------------------------
 +
    Checking system libraries.
 +
-----------------------------------
 +
----- checking zlib (required)
 +
checking for inflate in -lz... no
 +
Zlib missing, did you install zlib and zlib-developer packages?
 +
 +
what next? install zlib first?

Revision as of 17:19, 11 August 2006

having freelink 060801 for mips installed, i first had to find out, that mldonkey is part of debian unstable. managed to make unstable available to apt, but this is what i got installing mldonkey:


root@FL060801:~# apt-get install mldonkey-server Reading Package Lists... Done Building Dependency Tree... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation:

The following packages have unmet dependencies:

 mldonkey-server: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be installed
                  Depends: libgcc1 (>= 1:4.1.0) but 1:3.4.3-13 is to be installed
                  Depends: libncurses5 (>= 5.4-5) but 5.4-4 is to be installed
                  Depends: libstdc++6 (>= 4.1.0) but 3.4.3-13 is to be installed
                  Depends: ocaml-base-nox-3.09.2

E: Broken packages

so first i have to upgrade the libs - right?


tried to compile it instaed of digging into dependencies: but after ./configure --enable-batch --disable-gui i got in the end:


    Checking system libraries.


checking zlib (required)

checking for inflate in -lz... no Zlib missing, did you install zlib and zlib-developer packages?

what next? install zlib first?