Upgrade to the 2.6-kernel (ppc only)