Difference between revisions of "User:Davy gravy"

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
(What have I done about it?)
(Where has this led?)
Line 18: Line 18:
  
 
==Where has this led?==
 
==Where has this led?==
 +
Eventually, I wanted a bigger hda1 partition than was allowed for using the Buffalo installer app.  So, I did the following:
 +
*bargain hunted to find a Kurobox HG and a second-hand LS-HG, and learned how to perform the Kuro-style software installations,
 +
*gained a great appreciation for the work that people like Sylver, Frontalot and the current moderators have done,
 +
*flashed both my LS-HG and KuroHG with UBoot and the 2.4.33.3-v3 firmimg.bin so that I can always get into EM mode with impunity,

Revision as of 15:44, 21 January 2007

Contents

Why did I get a Linkstation?

I started out in 2005 with a Linkstation 2 (Mipsel), because we had a great need for some sort of network attached storage (NAS) for our work. After comparing everything on the market, it seemed like the Linkstation was the best fit for us, because:

  • it was economical from a power consumption standpoint (draws under 20 watts),
  • it plays well on a Mac-centric network,
  • it supports very large files, like .dmg files of size 10-30GB,
  • it was easy to set up, and
  • I trusted it once I had researched it and learned that it is Linux-based.

I had already used Yellow Dog Linux extensively, and had considered building my own NAS box from scratch, but couldn't find sufficiently small and power-stingy platform to base it on. I did cobble together a NAS using one of my old Macs and Linux, but decided to go with the Buffalo product as my own creation drew about 350 watts.

What about it didn't satisfy me?

We used this LS2 for about 9 months before I decided that I wasn't satisfied with the network speed. It's transfer speed of about 5MB/sec just wasn't what I was looking for.

What have I done about it?

I bought a gigabit-enabled LS-HG and much to my disappointment, I found the transfer speed was about the same. I tried the following remedies:

  • changing the network's and Linkstation's MTU using Openlink, with this wiki article on Performance Tuning the Network Controller (MTU). This gave no improvement.
  • upgrading to the 2.6 kernel. This resulted in some improvement, transfer rates around 8-10MB/sec. I was happy with this, but the ipkg system felt just a little restrictive for me.
  • installing Freelink and the 2.6 kernel using Freelinkomatix. This gave me the speed that I wanted, the software pool of Debian from which to draw on, and the flexibility of an open system.

Where has this led?

Eventually, I wanted a bigger hda1 partition than was allowed for using the Buffalo installer app. So, I did the following:

  • bargain hunted to find a Kurobox HG and a second-hand LS-HG, and learned how to perform the Kuro-style software installations,
  • gained a great appreciation for the work that people like Sylver, Frontalot and the current moderators have done,
  • flashed both my LS-HG and KuroHG with UBoot and the 2.4.33.3-v3 firmimg.bin so that I can always get into EM mode with impunity,