Difference between revisions of "User talk:Ramuk"

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
m (Get the archive)
m (Maybe not so much)
 
(33 intermediate revisions by 4 users not shown)
Line 1: Line 1:
=My Install=
+
=help with manual install=
 +
You seem to be the Freelink manual install expert.  I'm using your page and have all of the images in partitions on my hard drive.  Can't get it to boot from it.  I've changed the Uboot variables per the isntructions but it seems to find a uImage file that doesn't match what I saved to the boot partitiion.  And whatever it finds has a bad CRC.  Any suggestions?
  
==Get the archive==
+
<pre>
 +
Reset IDE:
 +
Marvell Serial ATA Adapter
 +
Integrated Sata device found
 +
  Device 0: OK
 +
Model: MAXTOR STM3320620AS                    Firm: 3.AAE    Ser#:            5QF57K4R
 +
            Type: Hard Disk
 +
            Supports 48-bit addressing
 +
            Capacity: 305245.3 MB = 298.0 GB (625142448 x 512)
  
[[image:Linkstation-debdux.gif|70px]]<big>'''[http://downloads.linkstationwiki.net/freelink/freelink_powerpc-hdhglan-1.11.zip freelink_powerpc-hdhglan-1.11.zip]'''</big>
+
Using device ide0, partition 1
  
==Flash The [[The LinkStation firmware flasher]]==
+
Loading from block device ide device 0, partition 1: Name: hda1
*Disable any firewall(s), '''including any built-in Windows firewall'''
+
  Type: U-Boot  File:/boot/uImage
*Make sure the LinkStation and your PC are on the same sub-network. This likely requires that you change the IP address (and probably the subnet-mask) of your PC to a different (and static) IP address (see the <tt>README</tt> file for the subnet).
+
*Run the firmware updater executable <tt>HD-HGLAN FWUpdate.exe</tt>
+
*After finding your LinkStation, press the "Renew Firmware" button, and wait. Have patience, and keep your calm. If you think the Firmware updater is acting strange, do not try to disconnect the LinkStation or abort the update in another way.
+
*Use a [[w:Telnet|Telnet]] ''(insecure communications protocol used for remote access to a host)'' client (we recommend  [[w:PuTTY|PuTTYtel]]) to connect to the LinkStation. You will be at the root shell.
+
  
==Login to the machine and get started==
+
0 bytes read
# telnet 192.168.1.XXX
+
<<stop_sound>>
Debian GNU/Linux 3.1 %h
+
## Booting image at 00100000 ...
root@LinkStation:/#
+
  Image Name:  Linux-2.6.12.6-arm1
===Change the root password===
+
  Created:     2007-04-10 13:45:13 UTC
passwd root
+
  Image
===Get and update with apt-get===
+
Type:  ARM Linux Kernel Image (uncompressed)
apt-get update
+
  Data Size:    1736548 Bytes = 1.7 MB
  apt-get install ssh
+
  Load Address: 00008000
apt-get upgrade
+
  Entry Point: 00008000
apt-get install samba smbfs
+
  Verifying Checksum ... Bad Data CRC
  apt-get install webmin webmin-core webmin-cpan webmin-inetd webmin-logrotate webmin-firewall
+
bootm fail.
apt-get install webmin-samba
+
<<system_not_found>>
rm /etc/rc2.d/S05utelnetd
+
Using egiga0 device
==[[Freeing up space on hda1]]==
+
TFTP from server 192.168.161.14; our IP address is 192.168.161.32
  cp -Rdp /home /mnt
+
Filename 'uImage.buffalo'.
rm -R  /home
+
Load address: 0x100000
ln -s /mnt/home /home
+
</pre>
cp -Rdp /usr /mnt
+
[[User:Mramsey|Mramsey]] 23:53, 24 March 2008 (CDT)
rm -R  /usr
+
ln -s /mnt/usr /usr
+
cp -Rdp /var /mnt
+
rm -R  /var
+
ln -s /mnt/var /var
+
==[[Correct the system time and setup Network Time Protocol (NTP)]]==
+
tzconfig
+
apt-get install ntp ntp-simple ntp-server ntpdate
+
==[[Upgrade to the 2.6-kernel (ppc only)]]==
+
wget http://hvkls.dyndns.org/downloads/latest-webinstaller.tar.gz
+
tar -C / -xvzf latest-webinstaller.tar.gz
+
/usr/local/sbin/webinstaller-kernelinst.sh
+
*'''''<font color=red>REBOOT</font>'''''
+
  
==Install an [[Encrypted Filespace with EncFS]]==
+
== Maybe not so much ==
wget  http://hvkls.dyndns.org/downloads/fuse_2.5.3-binaries-ppc.tar.gz
+
tar -C / -xvzf fuse_2.5.3-binaries-ppc.tar.gz
+
apt-get install encfs
+
  
==[[Troubleshooting Windows shares (samba)]] - guest access ==
+
Maybe not so much, you started a discussion in the forum
1. Pick a directory you wish to share ie: <tt>/mnt/share</tt> and change the access permissions to make it readable and writable to everybody.
+
http://buffalo.nas-central.org/forums/viewtopic.php?f=51&t=6881
mkdir /mnt/share
+
chmod 777 /mnt/share
+
2. Add the <tt>[share]</tt> section to <tt>'''/etc/samba/smb.conf'''</tt>
+
<pre>
+
[global]
+
security = share
+
workgroup = MSHOME
+
create mode = 777
+
directory mode = 777
+
  
[share]
+
I figured I'd reference it hereI hope you've got it working now.
comment = LinkStation Share
+
path = /mnt/share
+
read only = no
+
public = yes
+
</pre>           
+
3. Restart Samba on the Linkstation with this command:
+
  /etc/rc.d/init.d/smb restart
+
  
==[[Macintosh related configuration, netatalk, mt-daapd]]==
+
[[User:Ramuk|Ramuk]] 23:27, 27 March 2008 (CDT)
wget http://hvkls.dyndns.org/downloads/libid3tag_0.15.1b-binaries-ppc.tar.gz
+
wget http://hvkls.dyndns.org/downloads/mtdaapd_0.2.4-binaries-ppc.tar.gz
+
tar -C / -xvzf libid3tag_0.15.1b-binaries-ppc.tar.gz
+
tar -C / -xvzf mtdaapd_0.2.4-binaries-ppc.tar.gz
+
mv /etc/mt-daapd.SAMPLE /etc/mt-daapd
+
*Then edit /etc/mt-daapd/*. When done,
+
/etc/init.d/mt-daapd start
+
==[[Precompiled C development environment, running on the LS ]]==
+
mkdir tmp
+
cd tmp
+
wget http://downloads.linkstationwiki.net/development_tools/ppc-tools-2_1.tgz
+
mkdir devtools
+
cd devtools
+
tar xzvf ../ppc-tools-2_1.tgz
+
./install.sh
+
wget http://downloads.linkstationwiki.net/kernel_headers/kernel-headers-2.4.20_hglan_htgl-2.0.tar.bz2
+
tar -C / -xvjf kernel-headers-2.4.20_hglan_htgl-2.0.tar.bz2
+
==[[USB Palm OS Device as an LCD Display]]==
+
apt-get install lcdproc
+
apt-get remove lcdproc
+
wget http://lcdproc.omnipotent.net/download/lcdproc-0.4.5.tar.gz
+
tar -xvzf lcdproc-0.4.5.tar.gz
+
cd lcdproc-0.4.5
+
./configure
+
make
+
make install
+
==Install [[Ipkg on the Linkstation (for end-users)]]==
+
wget http://downloads.linkstationwiki.net/powerpc-hdhlan/powerpc-hdhlan-ipkg-0.99.153-1.tgz
+
tar -C / -xvzf powerpc-hdhlan-ipkg-0.99.153-1.tgz
+
*Add the following lines to the file /etc/ipkg.conf:
+
src nslu2-cross-stable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/cross/stable/
+
src nslu2-cross-unstable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/cross/unstable/
+
src nslu2-native-stable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/native/stable/
+
src nslu2-native-unstable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/native/unstable/
+
==[[XBMC - Using Xbox Media Center with the LinkStation]]==
+
ipkg install ccxstream
+
* Edit the ccxstream start file and change the username and shared directory for your system
+
'''''/opt/etc/init.d/S75ccxstream'''''
+
#!/bin/sh
+
+
if [ -n "`pidof ccxstream`" ] ; then
+
    killall ccxstream 2>/dev/null
+
+
fi
+
 
+
# see /opt/doc/ccxstream/README for the full summary on
+
# command-line options, but the terse summary is that
+
# -r is the directory to "share" using ccxstream, and is
+
# probably the option you most want to adjust.
+
#
+
+
sleep 2
+
<font color=red>/opt/sbin/ccxstream -r '''/mnt/share''' -u '''username''' -f -F /var/run/ccxstream.pid</font>
+
* Start the ccXStream daemon
+
/opt/etc/init.d/S75ccxstream
+

Latest revision as of 04:27, 28 March 2008

help with manual install

You seem to be the Freelink manual install expert. I'm using your page and have all of the images in partitions on my hard drive. Can't get it to boot from it. I've changed the Uboot variables per the isntructions but it seems to find a uImage file that doesn't match what I saved to the boot partitiion. And whatever it finds has a bad CRC. Any suggestions?

Reset IDE:
Marvell Serial ATA Adapter
Integrated Sata device found
  Device 0: OK
Model: MAXTOR STM3320620AS                    Firm: 3.AAE    Ser#:             5QF57K4R
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 305245.3 MB = 298.0 GB (625142448 x 512)

Using device ide0, partition 1

Loading from block device ide device 0, partition 1: Name: hda1
  Type: U-Boot  File:/boot/uImage

0 bytes read
<<stop_sound>>
## Booting image at 00100000 ...
   Image Name:   Linux-2.6.12.6-arm1
   Created:      2007-04-10  13:45:13 UTC
   Image 
Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1736548 Bytes =  1.7 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... Bad Data CRC
bootm fail.
<<system_not_found>>
Using egiga0 device
TFTP from server 192.168.161.14; our IP address is 192.168.161.32
Filename 'uImage.buffalo'.
Load address: 0x100000

Mramsey 23:53, 24 March 2008 (CDT)

Maybe not so much

Maybe not so much, you started a discussion in the forum http://buffalo.nas-central.org/forums/viewtopic.php?f=51&t=6881

I figured I'd reference it here. I hope you've got it working now.

Ramuk 23:27, 27 March 2008 (CDT)