Difference between revisions of "User talk:Ramuk"

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
m (Maybe not so much)
 
(29 intermediate revisions by 4 users not shown)
Line 1: Line 1:
=My Install=
+
=help with manual install=
==Get the archive==
+
You seem to be the Freelink manual install expert. I'm using your page and have all of the images in partitions on my hard drive. Can't get it to boot from it. I've changed the Uboot variables per the isntructions but it seems to find a uImage file that doesn't match what I saved to the boot partitiion. And whatever it finds has a bad CRC. Any suggestions?
[[image:Linkstation-debdux.gif|70px]]<big>'''[http://downloads.linkstationwiki.net/freelink/freelink_powerpc-hdhglan-1.11.zip freelink_powerpc-hdhglan-1.11.zip]'''</big>
+
==Flash The [[The LinkStation firmware flasher]]==
+
*Disable any firewall(s), '''including any built-in Windows firewall'''
+
*Make sure the LinkStation and your PC are on the same sub-network. This likely requires that you change the IP address (and probably the subnet-mask) of your PC to a different (and static) IP address: 192.186.11.XXX
+
*Run the firmware updater executable <tt>HD-HGLAN FWUpdate-english.exe</tt>
+
*After finding your LinkStation, press the "Renew Firmware" button, and wait. Have patience, and keep your calm. If you think the Firmware updater is acting strange, do not try to disconnect the LinkStation or abort the update in another way.
+
*After flashing connect your LinkStation up to the network with subnet 192.168.1.XXX
+
*Find your LinkStation on the network and [[w:Telnet|Telnet]] to it with [[w:PuTTY|PuTTYtel]] You will be at the root shell.
+
  
==Login to the machine and get started==
 
# telnet 192.168.1.XXX
 
Debian GNU/Linux 3.1 %h
 
root@LinkStation:/#
 
===Change the root password===
 
passwd root
 
===Get and update with apt-get===
 
apt-get update
 
apt-get install ssh
 
apt-get upgrade
 
apt-get install samba smbfs
 
apt-get install webmin webmin-core webmin-cpan webmin-inetd webmin-logrotate webmin-firewall
 
apt-get install webmin-samba
 
rm /etc/rc2.d/S05utelnetd
 
==[[Freeing up space on hda1]]==
 
cp -Rdp /home /mnt
 
rm -R  /home
 
ln -s /mnt/home /home
 
cp -Rdp /usr /mnt
 
rm -R  /usr
 
ln -s /mnt/usr /usr
 
cp -Rdp /var /mnt
 
rm -R  /var
 
ln -s /mnt/var /var
 
==[[Correct the system time and setup Network Time Protocol (NTP)]]==
 
tzconfig
 
apt-get install ntp ntp-simple ntp-server ntpdate
 
==[[Upgrade to the 2.6-kernel (ppc only)]]==
 
wget http://hvkls.dyndns.org/downloads/latest-webinstaller.tar.gz
 
tar -C / -xvzf latest-webinstaller.tar.gz
 
/usr/local/sbin/webinstaller-kernelinst.sh
 
*'''''<font color=red>REBOOT</font>'''''
 
==Install an [[Encrypted Filespace with EncFS]]==
 
wget  http://hvkls.dyndns.org/downloads/fuse_2.5.3-binaries-ppc.tar.gz
 
tar -C / -xvzf fuse_2.5.3-binaries-ppc.tar.gz
 
apt-get install encfs
 
==[[Troubleshooting Windows shares (samba)]] - guest access ==
 
1. Pick a directory you wish to share ie: <tt>/mnt/share</tt> and change the access permissions to make it readable and writable to everybody.
 
mkdir /mnt/share
 
chmod 777 /mnt/share
 
2. Add the <tt>[share]</tt> section to <tt>'''/etc/samba/smb.conf'''</tt>
 
 
<pre>
 
<pre>
[global]
+
Reset IDE:
security = share
+
Marvell Serial ATA Adapter
workgroup = MSHOME
+
Integrated Sata device found
create mode = 777
+
  Device 0: OK
directory mode = 777
+
Model: MAXTOR STM3320620AS                    Firm: 3.AAE    Ser#:            5QF57K4R
 +
            Type: Hard Disk
 +
            Supports 48-bit addressing
 +
            Capacity: 305245.3 MB = 298.0 GB (625142448 x 512)
  
[share]
+
Using device ide0, partition 1
comment = LinkStation Share
+
path = /mnt/share
+
read only = no
+
public = yes
+
</pre>           
+
3. Restart Samba on the Linkstation with this command:
+
/etc/rc.d/init.d/smb restart
+
==[[Macintosh related configuration, netatalk, mt-daapd]]==
+
wget http://hvkls.dyndns.org/downloads/libid3tag_0.15.1b-binaries-ppc.tar.gz
+
wget http://hvkls.dyndns.org/downloads/mtdaapd_0.2.4-binaries-ppc.tar.gz
+
tar -C / -xvzf libid3tag_0.15.1b-binaries-ppc.tar.gz
+
tar -C / -xvzf mtdaapd_0.2.4-binaries-ppc.tar.gz
+
mv /etc/mt-daapd.SAMPLE /etc/mt-daapd
+
*Then edit /etc/mt-daapd/*. When done,
+
/etc/init.d/mt-daapd start
+
==[[Precompiled C development environment, running on the LS ]]==
+
mkdir tmp
+
cd tmp
+
wget http://downloads.linkstationwiki.net/development_tools/ppc-tools-2_1.tgz
+
mkdir devtools
+
cd devtools
+
tar xzvf ../ppc-tools-2_1.tgz
+
./install.sh
+
wget http://downloads.linkstationwiki.net/kernel_headers/kernel-headers-2.4.20_hglan_htgl-2.0.tar.bz2
+
tar -C / -xvjf kernel-headers-2.4.20_hglan_htgl-2.0.tar.bz2
+
==[[USB Palm OS Device as an LCD Display]]==
+
apt-get install lcdproc
+
apt-get remove lcdproc
+
wget http://lcdproc.omnipotent.net/download/lcdproc-0.4.5.tar.gz
+
tar -xvzf lcdproc-0.4.5.tar.gz
+
cd lcdproc-0.4.5
+
./configure
+
make
+
make install
+
==Install [[Ipkg on the Linkstation (for end-users)]]==
+
wget http://downloads.linkstationwiki.net/powerpc-hdhlan/powerpc-hdhlan-ipkg-0.99.153-1.tgz
+
tar -C / -xvzf powerpc-hdhlan-ipkg-0.99.153-1.tgz
+
*Add the following lines to the file /etc/ipkg.conf:
+
src nslu2-cross-stable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/cross/stable/
+
src nslu2-cross-unstable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/cross/unstable/
+
src nslu2-native-stable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/native/stable/
+
src nslu2-native-unstable http://ipkg.nslu2-linux.org/feeds/optware/ds101g/native/unstable/
+
*then
+
ipkg update
+
  
==[[XBMC - Using Xbox Media Center with the LinkStation]]==
+
Loading from block device ide device 0, partition 1: Name: hda1
  ipkg install ccxstream
+
  Type: U-Boot File:/boot/uImage
* Edit the ccxstream start file and change the username and shared directory for your system
+
 
'''''/opt/etc/init.d/S75ccxstream'''''
+
0 bytes read
#!/bin/sh
+
<<stop_sound>>
+
## Booting image at 00100000 ...
if [ -n "`pidof ccxstream`" ] ; then
+
  Image Name:  Linux-2.6.12.6-arm1
    killall ccxstream 2>/dev/null
+
  Created:      2007-04-10 13:45:13 UTC
   
+
  Image
fi
+
Type:   ARM Linux Kernel Image (uncompressed)
    
+
  Data Size:    1736548 Bytes = 1.7 MB
  # see /opt/doc/ccxstream/README for the full summary on
+
  Load Address: 00008000
# command-line options, but the terse summary is that
+
  Entry Point: 00008000
  # -r is the directory to "share" using ccxstream, and is
+
  Verifying Checksum ... Bad Data CRC
# probably the option you most want to adjust.
+
bootm fail.
#
+
<<system_not_found>>
+
Using egiga0 device
sleep 2
+
TFTP from server 192.168.161.14; our IP address is 192.168.161.32
<font color=red>/opt/sbin/ccxstream -r '''/mnt/share''' -u '''username''' -f -F /var/run/ccxstream.pid</font>
+
Filename 'uImage.buffalo'.
* Start the ccXStream daemon
+
Load address: 0x100000
/opt/etc/init.d/S75ccxstream
+
</pre>
 +
[[User:Mramsey|Mramsey]] 23:53, 24 March 2008 (CDT)
 +
 
 +
== Maybe not so much ==
 +
 
 +
Maybe not so much, you started a discussion in the forum
 +
http://buffalo.nas-central.org/forums/viewtopic.php?f=51&t=6881
 +
 
 +
I figured I'd reference it here.  I hope you've got it working now.
 +
 
 +
[[User:Ramuk|Ramuk]] 23:27, 27 March 2008 (CDT)

Latest revision as of 04:27, 28 March 2008

help with manual install

You seem to be the Freelink manual install expert. I'm using your page and have all of the images in partitions on my hard drive. Can't get it to boot from it. I've changed the Uboot variables per the isntructions but it seems to find a uImage file that doesn't match what I saved to the boot partitiion. And whatever it finds has a bad CRC. Any suggestions?

Reset IDE:
Marvell Serial ATA Adapter
Integrated Sata device found
  Device 0: OK
Model: MAXTOR STM3320620AS                    Firm: 3.AAE    Ser#:             5QF57K4R
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 305245.3 MB = 298.0 GB (625142448 x 512)

Using device ide0, partition 1

Loading from block device ide device 0, partition 1: Name: hda1
  Type: U-Boot  File:/boot/uImage

0 bytes read
<<stop_sound>>
## Booting image at 00100000 ...
   Image Name:   Linux-2.6.12.6-arm1
   Created:      2007-04-10  13:45:13 UTC
   Image 
Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1736548 Bytes =  1.7 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... Bad Data CRC
bootm fail.
<<system_not_found>>
Using egiga0 device
TFTP from server 192.168.161.14; our IP address is 192.168.161.32
Filename 'uImage.buffalo'.
Load address: 0x100000

Mramsey 23:53, 24 March 2008 (CDT)

Maybe not so much

Maybe not so much, you started a discussion in the forum http://buffalo.nas-central.org/forums/viewtopic.php?f=51&t=6881

I figured I'd reference it here. I hope you've got it working now.

Ramuk 23:27, 27 March 2008 (CDT)