From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search


Lengthy NFS discussions have been moved to Talk:Terastation NFS. Please think carefully before deciding whether to post useful information to a Talk page or a normal article! Talk pages are often missed by the average reader.

Dead Terastation

In my over zealous hacking attempts, I have managed to kill the code in my flash. Is there a way to restore the flash code?

The TeraStation has a JTAG interface. It's part of the regular PowerPC debugging interface CN11. This 16pin interface is quite common for embedded PowerPCs, but I've forgotten it's name and don't have any useable links.
Unfortunately we don't have any JTAG-borderscan information, and without you will not be able to use the JTAG interface.
Sorry, but it looks like you're hossed. How did you destroy your flash anyway?
Come to think of it: unless you also destroyed the bootloader, you should be able to access it. Either from the serial port or even from the network. I've no further infrmation on this either.
You could ask buffalo, they have now at last learned how to use mdadm with a hacked firmware to recover a hossed raid.
--Bg 08:31, 4 April 2006 (CEST)

It was actually kinda stupid. I have two TeraStations, a TeraStation 1T and a TeraStation Pro 1T. I got the latest firmware for the Pro to add the AD support. I 'accidentally' applied the update to the non-pro box. After the TeraStation rebooted, it shutdown with the Diag light flashing. According to TeraStation docs:

 Five time continuous blinking(every four seconds)
 Flash ROM Error

The box is no longer accessible from the net. I thought I may be able to find some info on the root disk so I put it in a USB enclosure and mounted it using Suse. Of course there was nothing I could do because the kernel doesn't appear to load/execute from the flash. I haven't performed the console mod yet. Do think this might provide some useful output? Or should I just admit my stupidity and send the box back to buffalo for repair?

-- Update -- I performed the console mod and now I can see the boot messages (boot text). It appears the problem is that it's not loading an IDE driver ('cause the Pro doesn't use IDE?). Any Ideas? --Sjcook 14:52, 19 April 2006 (CEST)

Terrastation Root password.

I have just installed the Terastation 2.03 firmware from I currently have telnet access, and wish to install SSH, although I do not have root accesss. sudo does not work because there is no /etc/sudoers file, and I can't add anything to /etc/ due to my permissions. Does anyone know the default root password for 2.03? Thanks.

No, but feel free to crack it. It's btw. a lot easier to just make a modivied firmware image.
--Bg 14:52, 6 April 2006 (CEST)

Try This

is the root loging account should be "myroot" with a blank password.

Virtual Terastation

Hi, have just bought a Terastation and LinkTheater, like the idea of modding the TS for all these extra features, wondering if anyone has thought of testing it using a virtual PC (I have dd'ed the partitions of an old PC onto virtual disks created with QEMU ( and then run the old machine as a virtual one within vmplayer ( ) ? Is this something that anyone has considered - or does anyone have a copy of the linux partitions ? (A little nervous of opening the TS up as I now have data on it!) Thanks.

--Chris 12:36, 13 April 2006 (CEST)

Has anyone tried this.? WizardFusion

I'm currently trying to get VMware server to work over the network using NFS and a linux Host.. I'll try let you know how it goes :o)

Well, I have been doing some testing. My networks is 1Gps, and even though I have a very powerful host, the user mode NFS is just far too slow.

My next task is to try and get iSCSI working with my TSPro so it will act as a SAN. I have had this working fine using a normal Linux OS. I shall keep you all posted.

--- StPierre [29/10/2007]


Unfortunatly there is no HowTo for installing the LundFTPD. I tried to get it working but had no success. I downloaded and installed the precompiled Binary. Afer configuring the .conf file a litte bit i tried to start he deamon with /etc/init.d/lundftpd start - nothing happened (also no logfile action). when i tried to start the lundftpd manually with lundftpd -v a "segmentation fault" appeared.

Maybe there are some dependencies but i do not know which (there is no lundftpd readme.txt). If someone get the ftpd working please explain how (in the "hacking" page of this wiki).

I tried it with: Terastion 1TB, Disk Firmware 1.12 (Dave's hacked version)

Half Dead Terastation

Please read, and either laugh or cry.. After updating the firmware of my terastation to get root access to my box I started playing around. I found a heap of binaries that could be used with the terastation, so without looking through I untared everything.. (it all the packages looked useful) The downfall was that I replaced glibc and I get this error when i telnet to the box

in.telnetd: /lib/ version `GLIBC_2.3' not found (required by /lib/

SMB, apache, have also stopped working although FTP is good and healthy.

The only thing I can see possible now is for me to find an LPR exploit or try getting serial access.

I read through the documentation serial port guide on this site, although I am still wondering what exactly I need to do from a step-by-step persepctive.. Do I need to buy any resistors or jumpers? if so what type? etc.. Could anyone please help me out.


you crashed the diskfirmware, thats not an essential problem. i had an equal problem. after disconnecting the harddisks and playing with the firmware toy a bit the whole raid array was renewed therefore also the diskfirmware deleted. after this you can flash again and everything will work again regards, ringgh0st

Your 100% right!. I was so scared that if I rebooted my terastation it would render it unusable by not being able to boot. I also realised there was a factory reset button on the back of the unit as well.

Files missing from GPL archive

I received the Software#GPL_Software from Buffalo but it seems that they left out the hhl-host-rpmconfig* file that contains all the macros used to crossbuild their software.

Does anyone know where I can get a MontaVista 3.1 hhl-host-rpmconfig* file?


I am wondering if anyone has setup their terastation to be a torrenting box?--Tim@ 18:49, 22 July 2007 (CEST)

rtorrent looks like a good client to use. nslu2 mentions rtorrent. I have rtorrent setup on a server right now and all you have to do is drop a torrent into the "torrent" folder the corresponding file will appear in the "downloaded" file when complete. To seed I just add both torrent and data to the folders.

I am using CTorrent and Screen. ctorrent auf der TS - ENOSNUS