Talk:Non Flashable HD-HG300

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search
  • An alternative explanation is that this particular LS became popular at about the same time and sold well. Many people who didn't know what they where doing, and who couldn't follow instructions ("Disable all firewalls ...") tried to flash their shiny new LS. Instead of admitting they weren't up to the task they came up with the "some series must be broken!" excuse, and use isolated observations (defect flash prom in a single LS), to explain the theory. I think this is unfair - if you read the thread posted above you'll see that the suggestion of a duff series was made by European Technical support, and that they bricked one them selves whilst trying to flash using the stock firmware. I'm not a Linux guru but I am a professional programmer and like to think I'm able to disable a firewall where necessary... PaddyTB
  • The HG I repaired via JTAG uses the 2.4.31 kernel, telnet and ftp enabled firmware, and U-Boot. I was not able to repair it by flashing via U-Boot and had to use JTAG to install the new firmware, so there was something wrong or different about the hardware. Once U-boot and the new firmware were flashed via JTAG the HG worked perfectly. kuroguy


I've flash Openlink on 4 different HD-HG300's w/o incident. Sorry, I don't have the serial numbers handy. Hsum

Flashed once with stock firmware to test then again with Freelink. No problems at all. Serial 45803360612820

Success followed by Failure (this turned out to be no issue at all - everything was resolved without JTAG, nothing even broken...)

I've flashed a variety of Linkstations/relatives, with OpenLink and FreeLink. A Kuro, too. All successfully. Flashed an old KuroHG to UBoot w/o incident, a great improvement. When I tried replicate the same type of flash on my LS-HG 250, the image did not write correctly to the flash chip, apparently. The image file has been confirmed to be valid, so after examining the output of dd, comp and od of the files, it is my guess that the chip was defective somehow. Or it is write-protected (I find this unlikely, though). I only know that the process was the same as that others used. It was double-check. It simply did not work on this machine.

Luckily this has a chance to be fixed w/ JTAG.

A point to make here is that flashing w/ the Buffalo Updater is not the same as flashing the ROM w/ dd. This unit **did** flash w/ both OpenLInk and FreeLink, but did not w/ dd.

-- it was more a problem with the 2.6-kernel. while in 2.6-kernel, the flash is read only. so if you want to dd to the flash you need to get into the 2.4 kernel. 03:50, 17 November 2006 (EST)

Followup: there was no damage or problem w/ the flash at all. As correctly pointed out by several folks, the 2.6 kernel that I was using doesn't support writing to flash. I later did successfully flash my box w/ both U-Boot and a new v3 firmimg.bin.