Talk:TeraStation Pro(日本語)

From NAS-Central Buffalo - The Linkstation Wiki
Jump to: navigation, search

Entropy's firmware worked great for me. I am having couple of issues it might be my inexpertise. 1. Couldnt get the Pulic key authentication working. Tried using the tips on QandA. 2. NFS - i was able to mount both on mac and linux and i tried to copy a file little over than 2GB and got error. I would really appreciate any help. Thanks a Million - Nav

The UNFS that's included is V2 which has a 2G file limit. I'm going to try to get a V3 UNFS into a firmware but I've got too much going on at the moment - Entropy

Entropy could you tell me briefly how i can get V3 UNFS into the firmware. I will give it a shot. Appreciate your help. - Nav

I think there are a couple of ways you could approach getting UNFS V3 in the firmware.

  • Use Dan Kegel's crosstool to generate your own cross-compiler toolchain and compile the source yourself. On my 1GHz machine, just building the toolchain takes a couple hours and gigabytes of disk space. (Build for a PowerPC 603e) Whatever libraries that UNFS V3 needs will also have to be compiled. This will probably take a lot of effort and time as you will find bugs in packages that aren't tested to be cross-compiled.
  • Start with #1, cross-compile gcc and family to your TS. Then build UNFS3 for your TS. This will take a lot of time too I would guess, as the TS does not have a hefty CPU.
  • Try to find a cross compiler or gcc/toolchain already compiled for PPC 603e and work from there.
  • Try to find UNFS V3 compiled for a PPC host. This will require a good deal of luck, because if it's not statically compiled, you will need to make sure that your version matches the system library versions on your TS.

Once you have working binaries (you can ftp, or copy them using samba to your TS to test them), you want to update the firmware with your changes.

- Entropy

Thanks a lot for the info. It seems little bit out of my skills. -- Naveen